aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2009-06-16 17:52:15 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-16 17:52:15 +0200
commitbf05675a2007af645b1998d5b7c60ab7bf2dc1fc (patch)
tree11d41017cb0c864c054863164c7226f60bb7efd3 /configure.ac
parentaf23b83ea714756aa4bfed7f7501739c69428e40 (diff)
downloadudev-bf05675a2007af645b1998d5b7c60ab7bf2dc1fc.tar.gz
gudev: move from udev-extras
GObject libudev access. Initial version from Bastien Nocera, current version by David Zeuthen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9571c902..077944b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,20 @@ if test "x$enable_extras" = xyes; then
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])
+AC_ARG_ENABLE([introspection],
+ AS_HELP_STRING([--enable-introspection], [enable GObject introspection]),
+ [], [enable_introspection=no])
+if test "$enable_introspection" = xyes; then
+ PKG_CHECK_MODULES([INTROSPECTION], [gobject-introspection-1.0 >= 0.6.2])
+ AC_DEFINE([ENABLE_INTROSPECTION], [1], [enable GObject introspection support])
+ AC_SUBST([G_IR_SCANNER], [$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)])
+ AC_SUBST([G_IR_COMPILER], [$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)])
+ AC_SUBST([G_IR_GENERATE], [$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)])
+ AC_SUBST([GIRDIR], [$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)])
+ AC_SUBST([GIRTYPELIBDIR], [$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)])
+fi
+AM_CONDITIONAL([ENABLE_INTROSPECTION], [test "x$enable_introspection" = xyes])
+
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile
@@ -90,6 +104,10 @@ AC_CONFIG_FILES([
extras/scsi_id/Makefile
extras/usb_id/Makefile
extras/udev-acl/Makefile
+ extras/gudev/Makefile
+ extras/gudev/gudev-1.0.pc
+ extras/gudev/docs/Makefile
+ extras/gudev/docs/version.xml
])
AC_OUTPUT
@@ -100,6 +118,7 @@ AC_MSG_RESULT([
prefix: ${prefix}
exec_prefix: ${exec_prefix}
udev_prefix: ${udev_prefix}
+ libdir: ${libdir}
libdir_name: ${libdir_name}
datarootdir: ${datarootdir}
mandir: ${mandir}
@@ -114,6 +133,7 @@ AC_MSG_RESULT([
ldflags: ${LDFLAGS}
extras: ${enable_extras}
+ gintrospection: ${enable_introspection}
xsltproc: ${XSLTPROC}
])