aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-06-16 17:43:12 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-16 17:43:12 +0200
commitaf23b83ea714756aa4bfed7f7501739c69428e40 (patch)
tree1347ff8887b1b5de937a901b70fb25654f536b71 /configure.ac
parent1a669a701914badc6ecbeb29eb2cab1e17d0994b (diff)
downloadudev-af23b83ea714756aa4bfed7f7501739c69428e40.tar.gz
udev-acl: move from udev-extras
The build of extras with larger external dependencies is wrapped in: --enable-extras
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0df0f60f..9571c902 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,16 @@ if test "x$enable_logging" = "xyes"; then
AC_DEFINE(ENABLE_LOGGING, [1], [System logging.])
fi
+AC_ARG_ENABLE([extras],
+ AS_HELP_STRING([--enable-extras], [enable extras with external dependencies]),
+ [], [enable_extras=no])
+if test "x$enable_extras" = xyes; then
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
+ AC_SUBST([GLIB_CFLAGS])
+ AC_SUBST([GLIB_LIBS])
+fi
+AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])
+
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile
@@ -79,6 +89,7 @@ AC_CONFIG_FILES([
extras/rule_generator/Makefile
extras/scsi_id/Makefile
extras/usb_id/Makefile
+ extras/udev-acl/Makefile
])
AC_OUTPUT
@@ -102,5 +113,7 @@ AC_MSG_RESULT([
cflags: ${CFLAGS}
ldflags: ${LDFLAGS}
+ extras: ${enable_extras}
+
xsltproc: ${XSLTPROC}
])