aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-06-16 18:06:13 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-16 18:06:13 +0200
commit88a7923e91fddec8e4f4c9115168ede5d239d8ee (patch)
tree226907f975553cbf9f6e37645579e039aa338ef5 /configure.ac
parentbf05675a2007af645b1998d5b7c60ab7bf2dc1fc (diff)
downloadudev-88a7923e91fddec8e4f4c9115168ede5d239d8ee.tar.gz
INSTALL: add --enable-extras
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 077944b3..b4d00e84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,9 @@ if test "x$enable_extras" = xyes; then
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
AC_SUBST([GLIB_CFLAGS])
AC_SUBST([GLIB_LIBS])
+
+ AC_CHECK_LIB([acl], [acl_init], [:], AC_MSG_ERROR([libacl not found]))
+ AC_CHECK_HEADER([acl/libacl.h], [:], AC_MSG_ERROR([libacl header not found]))
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])