aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 20:05:55 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 20:05:55 +0200
commiteab32c2529ce53f9e01c12df739257511d58ebfb (patch)
treed380d0bc3f200d6f219af924bac33243b8ac1783 /Makefile.am
parent51668e2c8b7ffba73ec420f9896ea837d58f7c15 (diff)
downloadudev-eab32c2529ce53f9e01c12df739257511d58ebfb.tar.gz
Use the keymap check during “make distcheck” rather than “check”.
Since the check-keymaps.sh script checks for validity the source directory and the Makefile.am file, instead of running it during user-oriented “make check”, run it during developed-oriented “make distcheck”. An invalid keymap will abort the execution which will prevent shipping an incomplete Makefile.am. To properly support out-of-source builds, pass as single parameter to the test the path to the source directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d97af51..c6952978 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@ dist_udevconf_DATA = \
EXTRA_DIST = \
autogen.sh \
libudev/exported_symbols \
+ extras/keymap/check-keymaps.sh \
extras/gudev/gudevmarshal.list \
extras/gudev/gudevenumtypes.h.template \
extras/gudev/gudevenumtypes.c.template
@@ -386,10 +387,6 @@ BUILT_SOURCES += \
$(nodist_extras_keymap_keymap_SOURCES) \
$(dist_extras_gudev_libgudev_1_0_la_SOURCES)
-TESTS += extras/keymap/check-keymaps.sh
-
-check_DATA = extras/keymap/keys.txt
-
CLEANFILES += \
extras/keymap/keys.txt \
extras/keymap/keys-from-name.gperf
@@ -476,6 +473,8 @@ install-exec-hook: $(INSTALL_EXEC_HOOKS)
uninstall-hook: $(UNINSTALL_EXEC_HOOKS)
+distcheck-hook: keymaps-distcheck-hook
+
# move lib from $(libdir) to $(rootlib_execdir) and update devel link, if needed
libudev-install-move-hook:
if test "$(libdir)" != "$(rootlib_execdir)"; then \
@@ -493,6 +492,9 @@ udevacl-install-hook:
mkdir -p $(DESTDIR)$(prefix)/lib/ConsoleKit/run-session.d
ln -sf $(libexecdir)/udev-acl $(DESTDIR)$(prefix)/lib/ConsoleKit/run-session.d/udev-acl.ck
+keymaps-distcheck-hook: extras/keymap/keys.txt
+ ./extras/keymap/check-keymaps.sh $(top_srcdir)
+
# ------------------------------------------------------------------------------
# Custom rules
# ------------------------------------------------------------------------------