aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 19:44:30 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 19:44:30 +0200
commit51668e2c8b7ffba73ec420f9896ea837d58f7c15 (patch)
tree433a78380051dbd52ee647703fc013e02f6a9e97 /Makefile.am
parentf5fcc00997481fb8b2898fc579eae5bcbf930fae (diff)
downloadudev-51668e2c8b7ffba73ec420f9896ea837d58f7c15.tar.gz
Merge in Makefile.am.inc into Makefile.am
This removes another file from the distribution, since we're not using it anywhere else but the top-level Makefile.am file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 41d45a01..7d97af51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,3 @@
-include $(top_srcdir)/Makefile.am.inc
-
SUBDIRS = . libudev/docs
udevconfdir = $(sysconfdir)/udev
@@ -22,6 +20,20 @@ ACLOCAL_AMFLAGS = -I m4
AM_MAKEFLAGS = --no-print-directory
+AM_CPPFLAGS = \
+ -include $(top_builddir)/config.h \
+ -I$(top_srcdir)/libudev \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\"
+
+AM_CFLAGS =
+
+AM_LDFLAGS = \
+ -Wl,--as-needed
+
+udevrulesdir = \
+ $(libexecdir)/rules.d
+
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--enable-extras