aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2013-07-30 03:47:19 -0300
committerLucas De Marchi <lucas.demarchi@intel.com>2013-07-30 14:45:21 -0300
commit80cf2c8f05813b04a5479746ce3ddaef00ea240d (patch)
treef77029e4b4cd1f3587c982f02d73a420ac3fd39f /configure.ac
parentec6d026f26af3bc76365f2a40da758248d849809 (diff)
downloadkmod-80cf2c8f05813b04a5479746ce3ddaef00ea240d.tar.gz
build: Install bash completion data
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 194dfab..15c69d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,15 @@ AS_IF([test "x$with_zlib" != "xno"], [
AC_MSG_NOTICE([zlib support not requested])
])
+AC_ARG_WITH([bashcompletiondir],
+ AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
+ [],
+ [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
+ with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
+ ] , [
+ with_bashcompletiondir=${datadir}/bash-completion/completions
+ ])])
+AC_SUBST([bashcompletiondir], [$with_bashcompletiondir])
#####################################################################
# --enable-
@@ -194,7 +203,7 @@ AC_CONFIG_FILES([
AC_OUTPUT
AC_MSG_RESULT([
$PACKAGE $VERSION
- ======
+ =======
prefix: ${prefix}
sysconfdir: ${sysconfdir}
@@ -202,6 +211,7 @@ AC_MSG_RESULT([
rootlibdir: ${rootlibdir}
includedir: ${includedir}
bindir: ${bindir}
+ Bash completions dir: ${with_bashcompletiondir}
compiler: ${CC}
cflags: ${with_cflags} ${CFLAGS}