aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2011-12-10 22:19:41 -0200
committerGustavo Sverzut Barbieri <barbieri@profusion.mobi>2011-12-11 20:58:22 -0200
commit72c51a9e4d6b56f5454e53a6fc9b5c1bd923f227 (patch)
treeae6b81fe0552d86f32d553a9ca97175720c5531d /configure.ac
parentd01c67e38334ca5aa62e6c645e416d4989696294 (diff)
downloadkmod-72c51a9e4d6b56f5454e53a6fc9b5c1bd923f227.tar.gz
add lsmod, insmod and rmmod tools.
these tools are compatible with module-init-tools (except insmod does not take data from stdin).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 812f4ab..f5b16e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,11 @@ AC_C_TYPEOF
AM_PROG_CC_C_O
AC_PROG_GCC_TRADITIONAL
+AC_ARG_ENABLE([tools],
+ AS_HELP_STRING([--disable-tools], [disable building tools that provide same functionality as module-init-tools @<:@default=enabled@:>@]),
+ [], enable_tools=yes)
+AM_CONDITIONAL([BUILD_TOOLS], [test "x$enable_tools" = "xyes"])
+
AC_ARG_ENABLE([logging],
AS_HELP_STRING([--disable-logging], [disable system logging @<:@default=enabled@:>@]),
[], enable_logging=yes)
@@ -97,11 +102,13 @@ AC_MSG_RESULT([
sysconfdir: ${sysconfdir}
libdir: ${libdir}
includedir: ${includedir}
+ bindir: ${bindir}
compiler: ${CC}
cflags: ${CFLAGS}
ldflags: ${LDFLAGS}
+ tools: ${enable_tools}
logging: ${enable_logging}
debug: ${enable_debug}
])