aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-17 12:10:42 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-17 12:22:55 -0200
commit6068aaaea8e7cdc6039e6fd7a1aeab9db9d0225b (patch)
tree29417915f89114efc7562f2cc6c3cd89146469f5 /configure.ac
parent09e9ae58b6b463bea083eb5bb57665b87c08a66c (diff)
downloadkmod-6068aaaea8e7cdc6039e6fd7a1aeab9db9d0225b.tar.gz
Check if struct stat has mtim member
Not all libc's have a mtim member in struct stat (dietlibc doesn't). Change ts_usec() to receive a struct stat as parameter and implement it accordingly for both cases.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 66c2d51..19f78d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,9 @@ AS_IF([test "x$enable_debug" = "xyes"], [
AC_DEFINE(ENABLE_DEBUG, [1], [Debug messages.])
])
+# dietlibc doesn't have st.st_mtim struct member
+AC_CHECK_MEMBERS([struct stat.st_mtim], [], [], [#include <sys/stat.h>])
+
CC_CHECK_CFLAGS_APPEND([ \
-pipe \
-DANOTHER_BRICK_IN_THE \
@@ -125,7 +128,6 @@ CC_CHECK_CFLAGS_APPEND([ \
-Wl,--as-needed \
-Wl,--gc-sections])
-
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile