summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGeoff Levand <geoffrey.levand@am.sony.com>2007-05-08 17:33:11 -0700
committerSimon Horman <horms@verge.net.au>2007-05-09 15:42:44 +0900
commitdf5a80b73b34da3c8021608489400cb949e2f2e3 (patch)
tree5c3e31b2d63053d6e090eb736e334ccfa14ffd57 /configure.ac
parentee2bd75816cb20c266ad27e417589e8e6ee7a39e (diff)
downloadkexec-tools-df5a80b73b34da3c8021608489400cb949e2f2e3.tar.gz
kexec add strict-prototypes
Add the complier flag -Wstrict-prototypes to EXTRA_CFLAGS. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6b95f832..bcfbc58c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,7 @@ if test "${host_alias}" ; then
OBJDIR="$OBJDIR-${host_alias}"
fi
-EXTRA_CFLAGS='-Wall -g -fno-strict-aliasing $(CPPFLAGS) $(EXTRA_CPPFLAGS)'
+EXTRA_CFLAGS='-Wall -g -fno-strict-aliasing -Wstrict-prototypes $(CPPFLAGS) $(EXTRA_CPPFLAGS)'
BUILD_CFLAGS='-O2 -Wall $(CPPFLAGS)'
# Check whether ppc64. Add -m64 for building 64-bit binary