summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Kiper <dkiper@net-space.pl>2011-08-21 15:54:59 +0200
committerSimon Horman <horms@verge.net.au>2011-08-22 07:39:49 +0900
commit9c3215b5cbaaa5734835a726ffe1692f1fa4de9b (patch)
tree53e02dee569b9ea27331c444bfea909379e8456a /configure.ac
parent82fde208abae2fd9177539df594cb110c713935d (diff)
downloadkexec-tools-9c3215b5cbaaa5734835a726ffe1692f1fa4de9b.tar.gz
kexec/arch/i386: Add get_memory_ranges_xen() function
get_memory_ranges_sysfs() and get_memory_ranges_proc_iomem() are unreliable under Xen. Proper machine memory map could be obtained under Xen by calling __HYPERVISOR_memory_op hypercall with XENMEM_machine_memory_map argument. get_memory_ranges_xen() does that. It is implemented using ioctl() or libxenctrl interface. This solution is compatible with 3.x and 4.x Xen versions. Signed-off-by: Daniel Kiper <dkiper@net-space.pl> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 172a52a9..0d09bbae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,9 @@ if test "$with_xen" = yes ; then
AC_CHECK_HEADER(xenctrl.h,
AC_CHECK_LIB(xenctrl, xc_version, ,
AC_MSG_NOTICE([Xen support disabled])))
+ if test "$ac_cv_lib_xenctrl_xc_version" = yes ; then
+ AC_CHECK_FUNCS(xc_get_machine_memory_map)
+ fi
fi
dnl ---Sanity checks