summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKhalid Aziz <khalid_aziz@hp.com>2009-09-09 13:16:41 -0600
committerSimon Horman <horms@verge.net.au>2009-09-10 10:47:02 +1000
commit15302512abb2de7f253494d3ebaae7c68bcdca3c (patch)
tree471f223a44d62f049f67e387da9548bc2319b01b /configure.ac
parentc38ad602e15e5c7c4204d1a47e2fd1984cf98afb (diff)
downloadkexec-tools-15302512abb2de7f253494d3ebaae7c68bcdca3c.tar.gz
Fix a problem caused by autoconf 2.64 which redefined AC_MSG_ERROR
autoconf 2.64 redefined AC_MSG_ERROR and now a ";" is required at the end of AC_MSG_ERROR macro invocation in configure.ac. Absence of this ";" causes an "unexpected end of file" message when configure script generated by autoconf is run. This patch adds the ";" in right places. I have verified that configure.ac still works fine after these changes with autoconf 2.63 and 2.61. [horms@verge.net.au: removed trailing whitespace] Signed-off-by: Khalid Aziz <khalid.aziz@hp.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 4aade874..af6bbad3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,23 +150,23 @@ if test "$with_xen" = yes ; then
fi
dnl ---Sanity checks
-if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]) fi
-if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]) fi
-if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]) fi
-if test "$AS" = "no"; then AC_MSG_ERROR([as not found]) fi
-if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]) fi
-if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]) fi
-
-if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]) fi
-if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]) fi
-if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]) fi
-if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]) fi
-if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]) fi
-if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]) fi
-if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]) fi
-if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]) fi
-if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]) fi
-if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]) fi
+if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]); fi
+if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]); fi
+if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]); fi
+if test "$AS" = "no"; then AC_MSG_ERROR([as not found]); fi
+if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]); fi
+if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]); fi
+
+if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]); fi
+if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]); fi
+if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]); fi
+if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]); fi
+if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]); fi
+if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]); fi
+if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]); fi
+if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]); fi
+if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]); fi
+if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi
dnl ---Output variables...
AC_SUBST([BUILD_CC])