aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-10-09 11:16:39 +0200
committerMarcel Holtmann <marcel@holtmann.org>2010-10-09 11:16:39 +0200
commite63901aa3be63f086945d895dc8b1fcfcf03a189 (patch)
tree8654226b406ea6eae53cfeb69ff23f7cf3407c99 /configure.ac
parent729feb23cae5872a9c5aa15e12f908b807e7dd8c (diff)
downloadpacrunner-e63901aa3be63f086945d895dc8b1fcfcf03a189.tar.gz
Add simple libproxy implementation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e66e535..5f043f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,12 @@ AC_PROG_CC
AC_PROG_CC_PIE
AC_PROG_INSTALL
+m4_define([_LT_AC_TAGCONFIG], [])
+m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
AC_ARG_ENABLE(optimization, AC_HELP_STRING([--disable-optimization],
[disable code optimization through compiler]), [
if (test "${enableval}" = "no"); then
@@ -108,9 +114,13 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-test],
[enable test/example scripts]), [enable_test=${enableval}])
AM_CONDITIONAL(TEST, test "${enable_test}" = "yes")
+AC_ARG_ENABLE(libproxy, AC_HELP_STRING([--enable-libproxy],
+ [enable libproxy compatible library]), [enable_libproxy=${enableval}])
+AM_CONDITIONAL(LIBPROXY, test "${enable_libproxy}" = "yes")
+
AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[don't install configuration and data files]),
[enable_datafiles=${enableval}])
AM_CONDITIONAL(DATAFILES, test "${enable_datafiles}" != "no")
-AC_OUTPUT(Makefile src/pacrunner.service)
+AC_OUTPUT(Makefile src/pacrunner.service libproxy/libproxy-1.0.pc)