aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-09-19 12:50:10 +0900
committerMarcel Holtmann <marcel@holtmann.org>2010-09-19 12:50:10 +0900
commite417068bf8614fc656c5ba86ff9a9bab5375a418 (patch)
treea75899ba29a4a459f47804ce87ccffe13b37f5c9 /configure.ac
parentd64aecca8a1425b39d193bc41a055ea0b5fe438d (diff)
downloadpacrunner-e417068bf8614fc656c5ba86ff9a9bab5375a418.tar.gz
Require GLib thread support when using Mozilla Javascript engine
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 9 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2e1f5b8..45f2ac2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,14 +53,6 @@ PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.16, dummy=yes,
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
-if (test "${enable_threads}" = "yes"); then
- AC_DEFINE(NEED_THREADS, 1, [Define if threading support is required])
- PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.16, dummy=yes,
- AC_MSG_ERROR(GThread >= 2.16 is required))
- GLIB_CFLAGS="$GLIB_CFLAGS $GTHREAD_CFLAGS"
- GLIB_LIBS="$GLIB_LIBS $GTHREAD_LIBS"
-fi
-
PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.0, dummy=yes,
AC_MSG_ERROR(D-Bus >= 1.0 is required))
AC_CHECK_LIB(dbus-1, dbus_watch_get_unix_fd, dummy=yes,
@@ -69,7 +61,6 @@ AC_CHECK_LIB(dbus-1, dbus_watch_get_unix_fd, dummy=yes,
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
-
AC_ARG_WITH(dbusconf, AC_HELP_STRING([--with-dbusconf=PATH],
[path to D-Bus config directory]), [path_dbusconf=${withval}],
[path_dbusconf="`$PKG_CONFIG --variable=sysconfdir dbus-1`"])
@@ -90,12 +81,20 @@ if (test "${enable_capng}" = "yes"); then
AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
fi
-PKG_CHECK_MODULES(XUL, libxul >= 1.9, dummy=yes,
+PKG_CHECK_MODULES(XUL, libxul >= 1.9, enable_threads=yes,
AC_MSG_ERROR(XUL Runtime >= 1.9 is required))
XUL_LIBS="`$PKG_CONFIG --libs-only-L libxul` -lmozjs"
AC_SUBST(XUL_CFLAGS)
AC_SUBST(XUL_LIBS)
+if (test "${enable_threads}" = "yes"); then
+ AC_DEFINE(NEED_THREADS, 1, [Define if threading support is required])
+ PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.16, dummy=yes,
+ AC_MSG_ERROR(GThread >= 2.16 is required))
+ GLIB_CFLAGS="$GLIB_CFLAGS $GTHREAD_CFLAGS"
+ GLIB_LIBS="$GLIB_LIBS $GTHREAD_LIBS"
+fi
+
AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[don't install configuration and data files]),
[enable_datafiles=${enableval}])