aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-10-28 15:11:08 +0200
committerMarcel Holtmann <marcel@holtmann.org>2010-10-28 15:11:08 +0200
commitd22fedd81248b2b3f42af651af357fa8c48489cc (patch)
tree073bcb4ed9e73b559c3ee28e3f591be35bfd662c /configure.ac
parentb589f7143dfe1d03fb8c85a8c861eb85301c50ad (diff)
downloadpacrunner-d22fedd81248b2b3f42af651af357fa8c48489cc.tar.gz
Make CURL plugin a compile time option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index cd65605..d7983fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,11 +93,6 @@ else
fi
AC_SUBST(DBUS_DATADIR)
-PKG_CHECK_MODULES(CURL, libcurl >= 7.16, dummy=yes,
- AC_MSG_ERROR(CURL >= 7.16 is required))
-AC_SUBST(CURL_CFLAGS)
-AC_SUBST(CURL_LIBS)
-
AC_ARG_ENABLE(capng, AC_HELP_STRING([--enable-capng],
[enable capabilities support]), [enable_capng=${enableval}])
if (test "${enable_capng}" = "yes"); then
@@ -121,6 +116,16 @@ if (test "${enable_threads}" = "yes"); then
GLIB_LIBS="$GLIB_LIBS $GTHREAD_LIBS"
fi
+AC_ARG_ENABLE(curl, AC_HELP_STRING([--enable-curl],
+ [enable CURL plugin support]), [enable_capng=${enableval}])
+if (test "${enable_curl}" = "yes"); then
+ PKG_CHECK_MODULES(CURL, libcurl >= 7.16, dummy=yes,
+ AC_MSG_ERROR(CURL >= 7.16 is required))
+ AC_SUBST(CURL_CFLAGS)
+ AC_SUBST(CURL_LIBS)
+fi
+AM_CONDITIONAL(CURL, test "${enable_curl}" = "yes")
+
AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-test],
[enable test/example scripts]), [enable_test=${enableval}])
AM_CONDITIONAL(TEST, test "${enable_test}" = "yes")