aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2019-08-02 14:01:38 +0200
committerMarcel Holtmann <marcel@holtmann.org>2019-08-02 14:01:38 +0200
commit0e28c73fd7b3e2ac0b7d80a18dbe7d9d39e75503 (patch)
tree329a449797f87f25cdbf7cbf15c0b0a114ab9108 /Makefile.am
parent31b2f33c1b864e6b7ad089362f03a78b9eac7d0a (diff)
downloadpacrunner-0e28c73fd7b3e2ac0b7d80a18dbe7d9d39e75503.tar.gz
plugins: Remove support for V8 engine
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 0 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b99595..6b2bc6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,20 +37,6 @@ plugins_libmozjsplugin_a_SOURCES = plugins/mozjs.cc
plugins_libmozjsplugin_a_CXXFLAGS = $(AM_CFLAGS) @MOZJS_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
endif
-if V8
-js_sources = src/js_funcs.c
-builtin_modules += v8
-builtin_libadd += plugins/libv8plugin.a @V8_LIBS@
-
-# If we compile this into a v8.a library first, then autohell
-# won't use g++ to link pacrunner. And thus won't end up linking
-# against libstdc++ even in the builds where V8 is disabled.
-noinst_LIBRARIES += plugins/libv8plugin.a
-
-plugins_libv8plugin_a_SOURCES = plugins/v8.cc
-
-endif
-
if DUKTAPE
js_sources = src/js_funcs.c
builtin_modules += duktape
@@ -150,10 +136,6 @@ unit_test_mozjs_CXXFLAGS = $(AM_CFLAGS) @MOZJS_CFLAGS@
unit_test_mozjs_LDADD = @MOZJS_LIBS@ @GLIB_LIBS@ @PTHREAD_LIBS@
endif
-if V8
-unit_test_pacrunner_LDADD += plugins/libv8plugin.a @V8_LIBS@
-endif
-
if DUKTAPE
unit_test_pacrunner_SOURCES += plugins/duktape.c