aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fd66c8c..b754f73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,13 @@ DEFINES += -DSYSREGS_BASE=$(SYSREGS_BASE)
DEFINES += -DUART_BASE=$(UART_BASE)
BOOTLOADER := boot.S
+
+if PSCI
BOOTMETHOD := psci.o
+else
+BOOTMETHOD := spin.o
+endif
+
MBOX_OFFSET := 0xfff8
KERNEL_OFFSET := 0x80000
LD_SCRIPT := model.lds.S