aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-12-23 13:38:46 +0100
committerKay Sievers <kay.sievers@vrfy.org>2011-12-23 13:38:46 +0100
commitf71a55810f09fc010b44689aa00823a745ff83c6 (patch)
tree99a91329171c0264cc80db0691be6b618154a985 /configure.ac
parent749f464f9169acc5f0aa25c7ce5428353ebbe664 (diff)
downloadudev-f71a55810f09fc010b44689aa00823a745ff83c6.tar.gz
autogen.sh: moce CFLAGS from to configure.ac; print common ./configure options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index abfcb361..b8595664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,6 +201,14 @@ AC_ARG_ENABLE([edd],
[], [enable_edd=no])
AM_CONDITIONAL([ENABLE_EDD], [test "x$enable_edd" = "xyes"])
+my_CFLAGS="-Wall \
+-Wmissing-declarations -Wmissing-prototypes \
+-Wnested-externs -Wpointer-arith \
+-Wpointer-arith -Wsign-compare -Wchar-subscripts \
+-Wstrict-prototypes -Wshadow \
+-Wformat-security -Wtype-limits"
+AC_SUBST([my_CFLAGS])
+
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile