aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2010-01-25 08:22:47 +0100
committerKay Sievers <kay.sievers@vrfy.org>2010-01-25 08:22:47 +0100
commitd8f33f02527c5773438c2a29308edf25d06ce573 (patch)
tree71cfc39d143cc013175f6e26f858d683bb38abc1 /configure.ac
parent97411493a3f064b25ad9d3e1df99bf35f484eb3a (diff)
downloadudev-d8f33f02527c5773438c2a29308edf25d06ce573.tar.gz
keymap: linux/input.h - get absolute include path from gcc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08df0a9d..4cecb868 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,9 @@ if test "x$enable_extras" = xyes; then
AC_MSG_ERROR([pci.ids not found, try --with-pci-ids-path=])
fi])
AC_SUBST(PCI_DATABASE)
+
+ AC_CHECK_HEADER([linux/input.h], [:], AC_MSG_ERROR([kernel headers not found]))
+ AC_SUBST([INCLUDE_PREFIX], [$(echo '#include <linux/input.h>' | eval $ac_cpp -E - | sed -n '/linux\/input.h/ {s:.*"\(.*\)/linux/input.h".*:\1:; p; q}')])
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])
@@ -126,6 +129,8 @@ AC_MSG_RESULT([
mandir: ${mandir}
includedir: ${includedir}
+ include_prefix: ${INCLUDE_PREFIX}
+
logging: ${enable_logging}
debug: ${enable_debug}
selinux: ${with_selinux}