aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-07-14 02:02:35 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-07-14 02:02:35 +0200
commitc874e22e0da6f87aa72ade635f11421e6ecb6e48 (patch)
treeecf2b34607249f54a7732d681cc40f36c60c2784 /configure.ac
parent1985c76e48753c200b5a15630b00245c3f60775b (diff)
downloadudev-c874e22e0da6f87aa72ade635f11421e6ecb6e48.tar.gz
udev-acl: skip ACLs when systemd is running, disable by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 7bdb2290..d1327ab5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,20 +127,6 @@ fi
AM_CONDITIONAL([ENABLE_HWDB], [test "x$enable_hwdb" = xyes])
# ------------------------------------------------------------------------------
-# udev_acl - apply ACLs for users with local forground sessions
-# ------------------------------------------------------------------------------
-AC_ARG_ENABLE([udev_acl],
- AS_HELP_STRING([--disable-udev_acl], [disable local user acl permissions support]),
- [], [enable_udev_acl=yes])
-if test "x$enable_udev_acl" = xyes; then
- AC_CHECK_LIB([acl], [acl_init], [:], AC_MSG_ERROR([libacl not found]))
- AC_CHECK_HEADER([acl/libacl.h], [:], AC_MSG_ERROR([libacl header not found]))
-
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.22.0 gobject-2.0 >= 2.22.0])
-fi
-AM_CONDITIONAL([ENABLE_UDEV_ACL], [test "x$enable_udev_acl" = xyes])
-
-# ------------------------------------------------------------------------------
# GUdev - libudev gobject interface
# ------------------------------------------------------------------------------
AC_ARG_ENABLE([gudev],
@@ -184,6 +170,20 @@ fi
AM_CONDITIONAL([ENABLE_KEYMAP], [test "x$enable_keymap" = xyes])
# ------------------------------------------------------------------------------
+# udev_acl - apply ACLs for users with local forground sessions
+# ------------------------------------------------------------------------------
+AC_ARG_ENABLE([udev_acl],
+ AS_HELP_STRING([--enable-udev_acl], [enable local user acl permissions support]),
+ [], [enable_udev_acl=no])
+if test "x$enable_udev_acl" = xyes; then
+ AC_CHECK_LIB([acl], [acl_init], [:], AC_MSG_ERROR([libacl not found]))
+ AC_CHECK_HEADER([acl/libacl.h], [:], AC_MSG_ERROR([libacl header not found]))
+
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.22.0 gobject-2.0 >= 2.22.0])
+fi
+AM_CONDITIONAL([ENABLE_UDEV_ACL], [test "x$enable_udev_acl" = xyes])
+
+# ------------------------------------------------------------------------------
# create_floppy_devices - historical floppy kernel device nodes (/dev/fd0h1440, ...)
# ------------------------------------------------------------------------------
AC_ARG_ENABLE([floppy],