aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2011-02-15 16:31:49 +0100
committerMartin Pitt <martin.pitt@ubuntu.com>2011-02-15 16:31:49 +0100
commitc283cd6c598b38a6e1bb1ffd7372b9c550e45233 (patch)
tree64e17b0457b51179c685290fd0bcadd3f63285d8 /configure.ac
parent32567f8c95290a8819c0bc7d57849b8abfba9554 (diff)
downloadudev-c283cd6c598b38a6e1bb1ffd7372b9c550e45233.tar.gz
Fix building with --disable-extras
We always need to define automake conditionals, otherwise configure fails with --disable-extras.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2ceba561..c7885b01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,12 +115,12 @@ if test "x$enable_extras" = xyes; then
AC_CHECK_HEADER([linux/input.h], [:], AC_MSG_ERROR([kernel headers not found]))
AC_SUBST([INCLUDE_PREFIX], [$(echo '#include <linux/input.h>' | eval $ac_cpp -E - | sed -n '/linux\/input.h/ {s:.*"\(.*\)/linux/input.h".*:\1:; p; q}')])
-
- AC_CHECK_HEADER([linux/videodev.h], [have_videodev_h=yes], [])
- AM_CONDITIONAL(HAVE_V4L1, [test "x$have_videodev_h" = "xyes"])
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])
+AC_CHECK_HEADER([linux/videodev.h], [have_videodev_h=yes], [])
+AM_CONDITIONAL(HAVE_V4L1, [test "x$have_videodev_h" = "xyes"])
+
AC_ARG_ENABLE([introspection],
AS_HELP_STRING([--disable-introspection], [disable GObject introspection]),
[], [enable_introspection=yes])