aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMario Limonciello <mario_limonciello@dell.com>2009-06-16 19:30:22 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-16 19:30:22 +0200
commitbe51950dc4c20ba35af26e4d4d16c5298629e7a3 (patch)
tree1655578ba6cff2b178658d0d48ee8c32741482db /configure.ac
parent0303f35723f75157d8ef05be4d28b425aaa2fc45 (diff)
downloadudev-be51950dc4c20ba35af26e4d4d16c5298629e7a3.tar.gz
hid2hci: move from udev-extras
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 960a552e..82695b91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,10 @@ if test "x$enable_extras" = xyes; then
AC_CHECK_LIB([acl], [acl_init], [:], AC_MSG_ERROR([libacl not found]))
AC_CHECK_HEADER([acl/libacl.h], [:], AC_MSG_ERROR([libacl header not found]))
+
+ PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1.12)
+ AC_SUBST(LIBUSB_CFLAGS)
+ AC_SUBST(LIBUSB_LIBS)
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])
@@ -107,6 +111,7 @@ AC_CONFIG_FILES([
extras/scsi_id/Makefile
extras/usb_id/Makefile
extras/v4l_id/Makefile
+ extras/hid2hci/Makefile
extras/udev-acl/Makefile
extras/gudev/Makefile
extras/gudev/gudev-1.0.pc