aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScott James Remnant <scott@netsplit.com>2011-05-20 14:06:29 -0700
committerScott James Remnant <scott@netsplit.com>2011-05-23 12:32:55 -0700
commitbda2674f22b58bd32802b2057a05efada6155bae (patch)
tree4bcc0ae5fdbf4e86a91c60c7e6ee2cd25d071e6d /configure.ac
parentf085af8111a5c68b237ceee2cd988f296313ae4e (diff)
downloadudev-bda2674f22b58bd32802b2057a05efada6155bae.tar.gz
configure: allow usb.ids location to be specified
We already allow the pci.ids location to be specified, so add a patch doing the same for usb.ids. Please don't make me explain why this is necessary, it will only make you cry. Signed-off-by: Scott James Remnant <scott@netsplit.com> Signed-off-by: Kay Sievers <kay.sievers@vrfy.org> Acked-by: Greg Kroah-Hartman <gregkh@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3646f932..cfdb3bf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,8 +93,18 @@ if test "x$enable_hwdb" = xyes; then
AC_CHECK_FILES([/usr/share/misc/pci.ids], [pciids=/usr/share/misc/pci.ids])
fi
- PKG_CHECK_MODULES(USBUTILS, usbutils >= 0.82)
- AC_SUBST([USB_DATABASE], [$($PKG_CONFIG --variable=usbids usbutils)])
+ AC_ARG_WITH(usb-ids-path,
+ [AS_HELP_STRING([--with-usb-ids-path=DIR], [Path to usb.ids file])],
+ [USB_DATABASE=${withval}],
+ [if test -n "$usbids" ; then
+ USB_DATABASE="$usbids"
+ else
+ PKG_CHECK_MODULES(USBUTILS, usbutils >= 0.82)
+ AC_SUBST([USB_DATABASE], [$($PKG_CONFIG --variable=usbids usbutils)])
+ fi])
+ AC_MSG_CHECKING([for USB database location])
+ AC_MSG_RESULT([$USB_DATABASE])
+ AC_SUBST(USB_DATABASE)
AC_ARG_WITH(pci-ids-path,
[AS_HELP_STRING([--with-pci-ids-path=DIR], [Path to pci.ids file])],