aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Forney <mforney@mforney.org>2010-08-26 19:10:03 -0700
committerMartin Pitt <martin.pitt@ubuntu.com>2010-09-02 08:54:37 +0200
commit620343ddd674da8ef79ba55061c4bba83cd2d84b (patch)
treed4ab3b4564d5cff1cc7574c06fb084a6d410d4b9 /configure.ac
parentd4de0a0321b471e9dd8c32f1f3266b0b466457c7 (diff)
downloadudev-620343ddd674da8ef79ba55061c4bba83cd2d84b.tar.gz
Don't install systemd scripts with --without-systemdsystemunitdir
Currently, the scripts get installed to /no/ if that option is specified. Signed-off-by: Martin Pitt <martin.pitt@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0a18bb67..31c5b184 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,8 +66,10 @@ AC_SUBST([FIRMWARE_PATH], [$FIRMWARE_PATH])
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
[], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
-AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
-AM_CONDITIONAL(WITH_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(WITH_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
AC_ARG_ENABLE([extras],
AS_HELP_STRING([--disable-extras], [disable extras with external dependencies]),