aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-06-17 02:25:07 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-17 02:25:07 +0200
commit6133f3432fe86bc140cc9ba74794826f75c915fa (patch)
tree1199e3d6f005b66ea7b0d8b34d5ef323d7ee3cc0 /configure.ac
parent29cf5b58be1a783157edc37d7151d86acbdd5732 (diff)
downloadudev-6133f3432fe86bc140cc9ba74794826f75c915fa.tar.gz
cleanup ./configure installation directory options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 15 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index bba82ee7..c73872e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,4 @@
-AC_INIT([udev],
- [143],
- [linux-hotplug@vger.kernel.org])
+AC_INIT([udev], [143], [linux-hotplug@vger.kernel.org])
AC_PREREQ(2.60)
AM_INIT_AUTOMAKE([check-news foreign 1.9 dist-bzip2])
AC_DISABLE_STATIC
@@ -10,28 +8,17 @@ AC_SYS_LARGEFILE
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
GTK_DOC_CHECK(1.10)
-
-dnl /* prefix is /usr, exec_prefix is /, if overridden exec_prefix follows prefix */
AC_PREFIX_DEFAULT([/usr])
-test "$prefix" = NONE && test "$exec_prefix" = NONE && exec_prefix=
-
AC_PATH_PROG([XSLTPROC], [xsltproc])
-AC_ARG_WITH(udev-prefix,
- AS_HELP_STRING([--with-udev-prefix=DIR], [add prefix to internal udev path names]),
- [], [with_udev_prefix='${exec_prefix}'])
-udev_prefix=$with_udev_prefix
-AC_SUBST(udev_prefix)
+AC_ARG_WITH([rootlibdir],
+ AS_HELP_STRING([--with-rootlibdir=DIR], [rootfs directory to install shared libraries]),
+ [], [with_rootlibdir=$libdir])
+AC_SUBST([rootlibdir], [$with_rootlibdir])
-AC_ARG_WITH(libdir-name,
- AS_HELP_STRING([--with-libdir-name=DIR], [name of the arch lib directory]),
- [], [with_libdir_name=lib])
-libdir_name=$with_libdir_name
-AC_SUBST(libdir_name)
-
-AC_ARG_WITH(selinux,
+AC_ARG_WITH([selinux],
AS_HELP_STRING([--with-selinux], [enable SELinux support]),
- [], with_selinux=no)
+ [], [with_selinux=no])
if test "x$with_selinux" = xyes; then
LIBS_save=$LIBS
AC_CHECK_LIB(selinux, getprevcon,
@@ -44,14 +31,14 @@ fi
AC_SUBST([SELINUX_LIBS])
AM_CONDITIONAL(WITH_SELINUX, [test "x$with_selinux" = xyes])
-AC_ARG_ENABLE(debug,
+AC_ARG_ENABLE([debug],
AS_HELP_STRING([--enable-debug], [enable debug messages]),
- [], enable_debug=no)
+ [], [enable_debug=no])
if test "x$enable_debug" = "xyes"; then
AC_DEFINE(ENABLE_DEBUG, [1], [Debug messages.])
fi
-AC_ARG_ENABLE(logging,
+AC_ARG_ENABLE([logging],
AS_HELP_STRING([--disable-logging], [disable system logging]),
[], enable_logging=yes)
if test "x$enable_logging" = "xyes"; then
@@ -142,10 +129,12 @@ AC_MSG_RESULT([
========
prefix: ${prefix}
- exec_prefix: ${exec_prefix}
- udev_prefix: ${udev_prefix}
+ sysconfdir: ${sysconfdir}
+ sbindir: ${sbindir}
libdir: ${libdir}
- libdir_name: ${libdir_name}
+ rootlibdir: ${rootlibdir}
+ libexecdir: ${libexecdir}
+
datarootdir: ${datarootdir}
mandir: ${mandir}
includedir: ${includedir}