aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 02:01:29 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-08-07 19:15:28 +0200
commit59d93adb29fae25220955d44a5cd25f0d99e3528 (patch)
treed8137ed39ef6a4a54ebe0f2615b02251c24a7057 /configure.ac
parent4de08374d010ca85a932e11f0bac441561a10608 (diff)
downloadudev-59d93adb29fae25220955d44a5cd25f0d99e3528.tar.gz
Merge libudev, udev, and the unconditional extras in a single Makefile.am.
Instead of using multiple recursive Makefile.am files, use a single Makefile.am that sets and builds all the basic suite of libraries and binaries for udev. This reduces the number of files in the source tree, and also reduces drastically the build time when using parallel-make. With this setup, all the compile steps will be executed in parallel, and just the linking stage will be (partially) serialised on the libraries creation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index d4fb4e19..9041eeda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_INIT([udev], [146], [linux-hotplug@vger.kernel.org])
AC_PREREQ(2.60)
-AM_INIT_AUTOMAKE([check-news foreign 1.9 dist-bzip2])
+AM_INIT_AUTOMAKE([check-news foreign 1.9 dist-bzip2 subdir-objects])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_DISABLE_STATIC
AC_USE_SYSTEM_EXTENSIONS
@@ -101,27 +101,10 @@ AM_CONDITIONAL([ENABLE_INTROSPECTION], [test "x$enable_introspection" = xyes])
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile
- docs/Makefile
- libudev/Makefile
libudev/libudev.pc
libudev/docs/Makefile
libudev/docs/version.xml
- udev/Makefile
udev/udev.pc
- rules/Makefile
- extras/Makefile
- extras/ata_id/Makefile
- extras/cdrom_id/Makefile
- extras/edd_id/Makefile
- extras/path_id/Makefile
- extras/firmware/Makefile
- extras/collect/Makefile
- extras/floppy/Makefile
- extras/fstab_import/Makefile
- extras/rule_generator/Makefile
- extras/scsi_id/Makefile
- extras/usb_id/Makefile
- extras/v4l_id/Makefile
extras/hid2hci/Makefile
extras/udev-acl/Makefile
extras/usb-db/Makefile