aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-06-17 13:31:34 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-17 13:31:34 +0200
commit4b3be1c15836cfedcd017a6dd77fa1c3ac68a5f0 (patch)
tree46381a431c5e9f48470e73244ad517705d1fbf51 /configure.ac
parent181368a3b26329f77a93b06a5d2b285d4bf5f8e3 (diff)
downloadudev-4b3be1c15836cfedcd017a6dd77fa1c3ac68a5f0.tar.gz
configure.ac: print error if gperf is missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e81d999d..82c455dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,9 @@ AC_ARG_ENABLE([extras],
[], [enable_extras=yes])
if test "x$enable_extras" = xyes; then
AC_PATH_PROG([GPERF], [gperf])
+ if test -z "$GPERF"; then
+ AC_MSG_ERROR([gperf is needed])
+ fi
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
AC_SUBST([GLIB_CFLAGS])