aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-06-17 11:56:52 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-17 11:56:52 +0200
commit2417dc20f5147556d0ed4f95a37b1547fb4b0f2b (patch)
treeda5ee11aa30082e8f58cca252ab8b0c5ce973730 /configure.ac
parenta8aab0e95b18c772c91104c02a283d03180ff19f (diff)
downloadudev-2417dc20f5147556d0ed4f95a37b1547fb4b0f2b.tar.gz
keymap: move from udev-extras
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c73872e1..ec2a148a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,7 @@ dnl AM_SILENT_RULES
AC_SYS_LARGEFILE
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
+AC_PROG_AWK
GTK_DOC_CHECK(1.10)
AC_PREFIX_DEFAULT([/usr])
AC_PATH_PROG([XSLTPROC], [xsltproc])
@@ -49,6 +50,8 @@ AC_ARG_ENABLE([extras],
AS_HELP_STRING([--disable-extras], [disable extras with external dependencies]),
[], [enable_extras=yes])
if test "x$enable_extras" = xyes; then
+ AC_PATH_PROG([GPERF], [gperf])
+
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
AC_SUBST([GLIB_CFLAGS])
AC_SUBST([GLIB_LIBS])
@@ -121,6 +124,7 @@ AC_CONFIG_FILES([
extras/gudev/gudev-1.0.pc
extras/gudev/docs/Makefile
extras/gudev/docs/version.xml
+ extras/keymap/Makefile
])
AC_OUTPUT
@@ -154,4 +158,5 @@ AC_MSG_RESULT([
pci.ids: ${PCI_DATABASE}
xsltproc: ${XSLTPROC}
+ gperf: ${GPERF}
])