aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2009-06-04 01:44:04 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-06-04 01:44:04 +0200
commit1e03b754aef576a5cb75f01b1805cdc1f9cc292f (patch)
tree04fed54897345b57cfef598c3fe5eb00b93e53f8 /configure.ac
parentb61f48a0e8a4ad264bc0e904ea8bf3b054d5f562 (diff)
downloadudev-1e03b754aef576a5cb75f01b1805cdc1f9cc292f.tar.gz
udevd: convert to event worker processes
Event processes now get re-used after they handled an event. This reduces pressure on the CPU significantly because cloned event processes no longer cause page faults in the main daemon. After the events have settled, the no longer needed worker processes get killed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f1d008e0..9857d52e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,7 @@ AC_PREREQ(2.60)
AM_INIT_AUTOMAKE([check-news foreign 1.9 dist-bzip2])
AC_DISABLE_STATIC
AC_USE_SYSTEM_EXTENSIONS
+dnl AM_SILENT_RULES
AC_SYS_LARGEFILE
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
@@ -23,10 +24,6 @@ AC_SUBST(LIBUDEV_LT_AGE)
AC_PATH_PROG([XSLTPROC], [xsltproc])
-AC_CHECK_LIB(c, inotify_init,
- [AC_DEFINE([HAVE_INOTIFY], 1, [inotify available])],
- [AC_MSG_WARN([inotify support disabled])])
-
AC_ARG_WITH(udev-prefix,
AS_HELP_STRING([--with-udev-prefix=DIR], [add prefix to internal udev path names]),
[], [with_udev_prefix='${exec_prefix}'])