aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2011-02-15 14:20:21 +0100
committerMartin Pitt <martin.pitt@ubuntu.com>2011-02-15 14:20:21 +0100
commit0c0b3f97cad4c34140dda3aa85a9bc74badb4b16 (patch)
tree47b11e6f7c49d46facdf60b00e93174c7f642b1c /configure.ac
parent5e9eb156c003dc7f8f92287bfad0251d6c5d0ef9 (diff)
downloadudev-0c0b3f97cad4c34140dda3aa85a9bc74badb4b16.tar.gz
Only build v4l_id if V4L1 header file is available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d35cfce..2ceba561 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,9 @@ if test "x$enable_extras" = xyes; then
AC_CHECK_HEADER([linux/input.h], [:], AC_MSG_ERROR([kernel headers not found]))
AC_SUBST([INCLUDE_PREFIX], [$(echo '#include <linux/input.h>' | eval $ac_cpp -E - | sed -n '/linux\/input.h/ {s:.*"\(.*\)/linux/input.h".*:\1:; p; q}')])
+
+ AC_CHECK_HEADER([linux/videodev.h], [have_videodev_h=yes], [])
+ AM_CONDITIONAL(HAVE_V4L1, [test "x$have_videodev_h" = "xyes"])
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])