aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2010-06-25 10:30:55 +0200
committerKay Sievers <kay.sievers@vrfy.org>2010-06-25 10:30:55 +0200
commit08b4c88353b48302ae94088b55b2066ad01c63f8 (patch)
tree3bb20164d2568335b697518e1fafc09caa6d4f0b /configure.ac
parent43fefbf6f1c528947a77643582bcc34cf3538b2d (diff)
downloadudev-08b4c88353b48302ae94088b55b2066ad01c63f8.tar.gz
make: pre-process and install systemd service files when needed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4bac653b..255ee18b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,8 +49,7 @@ fi
AC_ARG_WITH(firmware-path,
AS_HELP_STRING([--with-firmware-path=DIR[[[:DIR[...]]]]],
[Firmware search path (default=/lib/firmware/updates:/lib/firmware)]),
- [], [with_firmware_path="/lib/firmware/updates:/lib/firmware"]
- )
+ [], [with_firmware_path="/lib/firmware/updates:/lib/firmware"])
OLD_IFS=$IFS
IFS=:
for i in $with_firmware_path
@@ -64,6 +63,12 @@ done
IFS=$OLD_IFS
AC_SUBST([FIRMWARE_PATH], [$FIRMWARE_PATH])
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(WITH_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+
AC_ARG_ENABLE([extras],
AS_HELP_STRING([--disable-extras], [disable extras with external dependencies]),
[], [enable_extras=yes])
@@ -126,10 +131,13 @@ AM_CONDITIONAL([ENABLE_INTROSPECTION], [test "x$enable_introspection" = xyes])
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_FILES([
Makefile
+ udev/udev.pc
+ init/udev.service
+ init/udev-settle.service
+ init/udev-retry.service
libudev/libudev.pc
libudev/docs/Makefile
libudev/docs/version.xml
- udev/udev.pc
extras/gudev/gudev-1.0.pc
extras/gudev/docs/Makefile
extras/gudev/docs/version.xml
@@ -153,6 +161,8 @@ AC_MSG_RESULT([
include_prefix: ${INCLUDE_PREFIX}
+ systemdsystemunitdir: ${systemdsystemunitdir}
+
logging: ${enable_logging}
debug: ${enable_debug}
selinux: ${with_selinux}