aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-03-23 16:40:23 +0100
committerKay Sievers <kay.sievers@vrfy.org>2011-03-23 16:40:23 +0100
commitfc1de713f5b754fb38876b5b797e18f812727f0a (patch)
treed9b9a7159f9a5a058f1918dbe4bce61c03bb6b28 /Makefile.am
parenta31d76b18675a0bf213fdd16242b4268c9ff48e0 (diff)
downloadudev-fc1de713f5b754fb38876b5b797e18f812727f0a.tar.gz
systemd: bind udev control socket in systemd and split udev.service
We should bind the udev socket from systemd, so we are sure that the abstract namespace socket is always bound by a root process and there is never a window during an update where an untrusted process can steal our socket. Also split the udev.service file, so that the daemon can be updated/restarted without triggering any coldplug events.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 40f13e79..7ad9a242 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,14 +124,20 @@ sharepkgconfig_DATA = udev/udev.pc
if WITH_SYSTEMD
systemdsystemunit_DATA = \
+ init/udev.socket \
init/udev.service \
+ init/udev-trigger.service \
init/udev-settle.service
+EXTRA_DIST += init/udev.socket
+
systemd-install-hook:
+ mkdir -p $(DESTDIR)$(systemdsystemunitdir)/socket.target.wants
+ ln -sf ../udev.socket $(DESTDIR)$(systemdsystemunitdir)/socket.target.wants/udev.socket
mkdir -p $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants
ln -sf ../udev.service $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants/udev.service
+ ln -sf ../udev-trigger.service $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants/udev-trigger.service
ln -sf ../udev-settle.service $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants/udev-settle.service
- ln -sf ../udev-retry.service $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants/udev-retry.service
INSTALL_DATA_HOOKS += systemd-install-hook
endif