aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-12-25 20:41:52 +0100
committerKay Sievers <kay.sievers@vrfy.org>2011-12-25 20:41:52 +0100
commitdd8a93e0d8d4db1810e8d0bc438c19c97876b810 (patch)
treee6e390763de74d35c089914cbb4bc76a0ffbced1 /Makefile.am
parent80df994cc22eb7f98187df9bc2281c7fd7b96af7 (diff)
downloadudev-dd8a93e0d8d4db1810e8d0bc438c19c97876b810.tar.gz
make: introduce --with-rootprefix=
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 18 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 769a6f50..a7f29676 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,9 +40,10 @@ libexec_SCRIPTS =
dist_libexec_SCRIPTS =
SED_PROCESS = \
-$(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
-e 's,@VERSION\@,$(VERSION),g' \
-e 's,@prefix\@,$(prefix),g' \
+ -e 's,@rootprefix\@,$(rootprefix),g' \
-e 's,@exec_prefix\@,$(exec_prefix),g' \
-e 's,@libdir\@,$(libdir),g' \
-e 's,@includedir\@,$(includedir),g' \
@@ -56,11 +57,16 @@ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
%.rules: %.rules.in Makefile
$(SED_PROCESS)
-%.service: %.service.in
+%.service: %.service.in Makefile
$(SED_PROCESS)
-%.sh: %.sh.in
+%.sh: %.sh.in Makefile
$(SED_PROCESS)
+ $(AM_V_GEN)chmod +x $@
+
+%.pl: %.pl.in Makefile
+ $(SED_PROCESS)
+ $(AM_V_GEN)chmod +x $@
# ------------------------------------------------------------------------------
# libudev
@@ -271,7 +277,15 @@ udev/%.html : udev/%.xml
# ------------------------------------------------------------------------------
# udev tests
# ------------------------------------------------------------------------------
-TESTS = test/udev-test.pl test/rules-test.sh
+TESTS = \
+ test/udev-test.pl \
+ test/rules-test.sh
+
+EXTRA_DIST += \
+ test/udev-test.pl.in
+
+CLEANFILES += \
+ test/udev-test.pl
check_PROGRAMS = \
libudev/test-libudev \