aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-10-10 20:27:20 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-10-10 20:27:20 +0200
commitd964a4bfde57ad1b05d105edd5d078e1aac45da6 (patch)
treee399dfd2c249248c7666c58e2a82f7f8abbf9e95 /Makefile.am
parentc61e36b1b49cc8bafd3f93a12a952d01658ff75e (diff)
downloadudev-d964a4bfde57ad1b05d105edd5d078e1aac45da6.tar.gz
udevd: install into /lib/udev instead of /sbin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d8b1889c..0cc45e6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,9 +151,11 @@ INSTALL_DATA_HOOKS += systemd-install-hook
endif
sbin_PROGRAMS = \
- udev/udevd \
udev/udevadm
+libexec_PROGRAMS = \
+ udev/udevd
+
udev_common_sources =\
udev/udev.h \
udev/udev-event.c \
@@ -233,7 +235,7 @@ extras_firmware_firmware_SOURCES = extras/firmware/firmware.c
extras_firmware_firmware_LDADD = libudev/libudev-private.la
extras_firmware_firmware_CPPFLAGS = $(AM_CPPFLAGS) -DFIRMWARE_PATH="$(FIRMWARE_PATH)"
dist_udevrules_DATA += extras/firmware/50-firmware.rules
-libexec_PROGRAMS = extras/firmware/firmware
+libexec_PROGRAMS += extras/firmware/firmware
# ------------------------------------------------------------------------------
# ata_id - ATA identify