aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2010-09-21 12:45:52 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2010-09-21 12:45:52 +0200
commitb2ad12eb0291832134bf3757f98abfeeec2fb166 (patch)
tree9b088e654df08400c537fedbb22f417ea3a77b0a /Makefile.am
parentc112a41a43ccede3b22bf242bcf8da455ca57c98 (diff)
downloadudev-b2ad12eb0291832134bf3757f98abfeeec2fb166.tar.gz
Add automatic rules syntax check
Add test/rule-syntax-check.py, a script for checking the syntax of all udev rules files passed as command line arguments. Add a wrapper test/rules-test.sh which calls rule-syntax-check.py on all udev rules that we ship, but does nothing if Python is not available. Integrate this into make check/distcheck.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 44cf0021..f1243963 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -183,7 +183,7 @@ EXTRA_DIST += \
# ------------------------------------------------------------------------------
# udev tests
# ------------------------------------------------------------------------------
-TESTS = test/udev-test.pl
+TESTS = test/udev-test.pl test/rules-test.sh
check_PROGRAMS = \
libudev/test-libudev \
@@ -619,6 +619,7 @@ CLEANFILES += \
$(BUILT_SOURCES)
EXTRA_DIST += $(TESTS)
+EXTRA_DIST += test/rule-syntax-check.py
install-exec-hook: $(INSTALL_EXEC_HOOKS)