aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2012-01-12 00:18:41 +0100
committerKay Sievers <kay.sievers@vrfy.org>2012-01-12 00:18:41 +0100
commitafa462dc182c0176a0c9f0afb5db1e0080c499f5 (patch)
tree9da82a74f01a3e8c4c636e947ef5850ca57625bf /Makefile.am
parentd8d2af0635507623971ce59e058847a700978cd8 (diff)
downloadudev-afa462dc182c0176a0c9f0afb5db1e0080c499f5.tar.gz
Makefile: update kernel.org sign and upload hook
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 46f923ea..d034baf5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -755,16 +755,16 @@ git-release:
git tag -m "udev $(VERSION)" -s $(VERSION)
git gc --prune=0
-tar:
- make distcheck
- gpg --armor --detach-sign udev-$(VERSION).tar.xz
-
git-sync:
git push
git push --tags $(VERSION)
+tar:
+ make distcheck
+ xz -d -c udev-$(VERSION).tar.xz | gpg --armor --detach-sign --output udev-$(VERSION).tar.asc
+
tar-sync:
- scp udev-$(VERSION).tar.xz master.kernel.org:/pub/linux/utils/kernel/hotplug/
+ kup put udev-$(VERSION).tar.xz udev-$(VERSION).tar.asc /pub/linux/utils/kernel/hotplug/udev-$(VERSION).tar.gz
doc-sync:
rsync -av src/*.html master.kernel.org:/pub/linux/utils/kernel/hotplug/udev/