aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-10-20 00:01:02 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-10-20 00:01:02 +0200
commitaf9cfc11909b3c33f86f495fc0a48e53fdabb32d (patch)
tree6c4c42bb8b12c2e7a8f5d5949c0000403ae9e7d8 /Makefile.am
parentb3eccdce81d18ec36c6ea95ac161002fc33d1810 (diff)
downloadudev-af9cfc11909b3c33f86f495fc0a48e53fdabb32d.tar.gz
make: add gpg signing bits
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cc45e6f..a67e2f34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -679,9 +679,14 @@ git-release:
head -1 ChangeLog | grep -q "to v$(VERSION)"
head -1 NEWS | grep -q "udev $(VERSION)"
git commit -a -m "release $(VERSION)"
- git tag $(VERSION)
+ git tag -m "udev $(VERSION)" -s $(VERSION)
git gc --prune=0
+tar:
+ make distcheck
+ gpg --armor --detach-sign udev-$(VERSION).tar.gz
+ gpg --armor --detach-sign udev-$(VERSION).tar.bz2
+
git-sync:
git push
git push --tags $(VERSION)