aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-11-30 18:38:43 +0100
committerMartin Pitt <martin.pitt@ubuntu.com>2009-11-30 18:38:43 +0100
commita6cf7734015dfc4479f4fdd4585d8953979fe0b0 (patch)
treecfea8e3acc45d4434c599db11abdebc0fd8c3358 /Makefile.am
parentd6b5571c1237c0a8e49dfc148615309f9c1a6c5c (diff)
downloadudev-a6cf7734015dfc4479f4fdd4585d8953979fe0b0.tar.gz
extras: Add input_id
input_id probes input/event devices for their class (keyboard, keys, mouse, touchpad, tablet, joystick). This is based on the corresponding hal code in hald/linux/device.c, input_test_{abs,rel,...}. This should provide enough functionality to get hal-less X.org working (which in particular needs to know exactly which devices are touchpads). Replace the brittle hacks in 60-persistent-input.rules with checking for the new ID_INPUT_* flags. This keeps the old ID_CLASS properties for now (but they are to be removed later on). Note: The current code has several hacks still, which are to be replaced with proper libudev calls later on.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 08ff1578..883cfc8c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -237,6 +237,12 @@ extras_floppy_create_floppy_devices_LDADD = libudev/libudev-private.la
libexec_PROGRAMS += extras/floppy/create_floppy_devices
# ------------------------------------------------------------------------------
+# usb_id - USB device property import
+# ------------------------------------------------------------------------------
+extras_input_id_input_id_SOURCES = extras/input_id/input_id.c
+libexec_PROGRAMS += extras/input_id/input_id
+
+# ------------------------------------------------------------------------------
# path_id - compose identifier of persistent elements of the parent buses
# ------------------------------------------------------------------------------
extras_path_id_path_id_SOURCES = extras/path_id/path_id.c