aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-10-30 09:38:21 +0100
committerMartin Pitt <martin.pitt@ubuntu.com>2009-10-30 09:38:21 +0100
commit82c6558e0109f66091e3a8e2c4ceef0372b0b331 (patch)
treebd20646828af8ee04f8d2253fb274e875e75a3f4 /Makefile.am
parent5448cc56f674b49aa0a2d718cac4266e18286712 (diff)
downloadudev-82c6558e0109f66091e3a8e2c4ceef0372b0b331.tar.gz
Makefile.am: fix build with mawk
Don't use the [[:space:]] syntax in awk calls' regex, since that's GNU awk specific. Thanks to Alan Jenkins for finding this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a6043371..84f16547 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -530,7 +530,7 @@ dist_udevkeymap_DATA = \
extras/keymap/keymaps/zepto-znote
extras/keymap/keys.txt: /usr/include/linux/input.h
- $(AM_V_GEN)$(AWK) '/^#define.*KEY_[^ ]+[[:space:]]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' < $< | sed 's/^KEY_COFFEE$$/KEY_SCREENLOCK/' > $@
+ $(AM_V_GEN)$(AWK) '/^#define.*KEY_[^ ]+[ \t]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' < $< | sed 's/^KEY_COFFEE$$/KEY_SCREENLOCK/' > $@
extras/keymap/keys-from-name.gperf: extras/keymap/keys.txt
$(AM_V_GEN)$(AWK) 'BEGIN{ print "struct key { const char* name; unsigned short id; };"; print "%null-strings"; print "%%";} { print $$1 ", " $$1 }' < $< > $@