aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2009-09-09 15:22:48 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2009-09-09 15:22:48 +0200
commit7f06ec2e19387424de34bae35320c2fe192cb69d (patch)
tree5b1cef1d0231a638f92288088ef78179b094cfb2 /Makefile.am
parent6983c0d0f2e396102118016eb7d9dafb3e193d57 (diff)
downloadudev-7f06ec2e19387424de34bae35320c2fe192cb69d.tar.gz
extras/keymap: Rename KEY_COFFEE to KEY_SCREENLOCK
Unfortunately KEY_COFFEE is the canonical name in linux/input.h, and the more sensible KEY_SCREENLOCK is an alias. Manually override this particular case, since it's better to have "screenlock" in keymaps. However, we still keep the automatic filtering for the general case, to avoid introducing this problem again when input.h changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f8ca8c3..5a6bc80a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -528,7 +528,7 @@ dist_udevkeymap_DATA = \
extras/keymap/keymaps/zepto-znote
extras/keymap/keys.txt: /usr/include/linux/input.h
- $(AM_V_GEN)$(AWK) '/^#define.*KEY_[^ ]+[[:space:]]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' < $< > $@
+ $(AM_V_GEN)$(AWK) '/^#define.*KEY_[^ ]+[[:space:]]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' < $< | sed 's/^KEY_COFFEE$$/KEY_SCREENLOCK/' > $@
extras/keymap/keys-from-name.gperf: extras/keymap/keys.txt
$(AM_V_GEN)$(AWK) 'BEGIN{ print "struct key { const char* name; unsigned short id; };"; print "%null-strings"; print "%%";} { print $$1 ", " $$1 }' < $< > $@