aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-06-03 14:38:43 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-06-03 14:38:43 +0200
commit6cadb40abf964141fe8c956dd6808f4885321eb6 (patch)
treebe90cae405b8b2ab676887f29438d9c46ca238bb /Makefile.am
parentbe903bf9c48b41bdfcff205efa5fc593b7174e86 (diff)
downloadudev-6cadb40abf964141fe8c956dd6808f4885321eb6.tar.gz
make: use 'git tag'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 998a3859..af9f8435 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -695,9 +695,12 @@ git-release:
head -1 ChangeLog | grep -q "to v$(VERSION)"
head -1 NEWS | grep -q "udev $(VERSION)"
git commit -a -m "release $(VERSION)"
- cat .git/refs/heads/master > .git/refs/tags/$(VERSION)
- git gc
- git prune
+ git tag $(VERSION)
+ git gc --prune=0
+
+git-sync:
+ git push
+ git push --tags $(VERSION)
tar-sync:
scp udev-$(VERSION).gz master.kernel.org:/pub/linux/utils/kernel/hotplug/