aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2010-06-12 23:52:52 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2010-06-13 00:47:16 +0200
commit6a7b5ec7712ea53fd756b07036e23ac0d751cec4 (patch)
tree77b72440441204576a5673563d5bb76fc8d092f0 /Makefile.am
parentba854cf8c32a85e9415debdb8d2a7292ddb3c452 (diff)
downloadudev-6a7b5ec7712ea53fd756b07036e23ac0d751cec4.tar.gz
add Vala vapi for gudev-1.0
Add gudev-1.0.vapi. This is based on the output of vapigen --library gudev-1.0 GUdev-1.0.gir with fixes to array/list semantics and include file names.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bafe4c7f..010cc714 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -350,11 +350,17 @@ extras_gudev_libgudev_1_0_la_LDFLAGS = \
-export-dynamic -no-undefined \
-export-symbols-regex '^g_udev_.*'
+gudev-install-hook:
+ install -D -m 644 $(top_srcdir)/extras/gudev/gudev-1.0.vapi $(DESTDIR)$(prefix)/share/vala/vapi/gudev-1.0.vapi
+
+INSTALL_EXEC_HOOKS += gudev-install-hook
+
EXTRA_DIST += \
extras/gudev/COPYING \
extras/gudev/gudevmarshal.list \
extras/gudev/gudevenumtypes.h.template \
- extras/gudev/gudevenumtypes.c.template
+ extras/gudev/gudevenumtypes.c.template \
+ extras/gudev/gudev-1.0.vapi
extras/gudev/gudevmarshal.h: extras/gudev/gudevmarshal.list
$(AM_V_GEN)glib-genmarshal $< --prefix=g_udev_marshal --header > $@