aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-05-20 14:41:10 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-05-20 14:41:10 +0200
commit666fcf03bceea8e8dd6c4510220036d1b949b814 (patch)
tree7815a318981dbd99bed5be2aa42044b0d67db629 /Makefile.am
parente5fd444fee244a3a15fc4ab59f662a341e985565 (diff)
downloadudev-666fcf03bceea8e8dd6c4510220036d1b949b814.tar.gz
libudev: export symbols explicitely and individually from C code not from separate file or prefix match
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b0d6a37..1537d56e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,7 @@ dist_libexec_SCRIPTS =
# libudev
# ------------------------------------------------------------------------------
LIBUDEV_CURRENT=11
-LIBUDEV_REVISION=4
+LIBUDEV_REVISION=5
LIBUDEV_AGE=11
SUBDIRS += libudev/docs
@@ -60,12 +60,8 @@ libudev_libudev_la_SOURCES =\
libudev/libudev-monitor.c \
libudev/libudev-queue.c
-libudev_libudev_la_CFLAGS = \
- -fvisibility=default
-
libudev_libudev_la_LDFLAGS = \
- -version-info $(LIBUDEV_CURRENT):$(LIBUDEV_REVISION):$(LIBUDEV_AGE) \
- -export-symbols $(top_srcdir)/libudev/exported_symbols
+ -version-info $(LIBUDEV_CURRENT):$(LIBUDEV_REVISION):$(LIBUDEV_AGE)
noinst_LTLIBRARIES = \
libudev/libudev-private.la
@@ -85,7 +81,7 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libudev/libudev.pc
-EXTRA_DIST += libudev/exported_symbols libudev/COPYING
+EXTRA_DIST += libudev/COPYING
# move lib from $(libdir) to $(rootlib_execdir) and update devel link, if needed
libudev-install-move-hook:
if test "$(libdir)" != "$(rootlib_execdir)"; then \