aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllin Cottrell <cottrell@wfu.edu>2011-07-19 21:16:22 +0200
committerKay Sievers <kay.sievers@vrfy.org>2011-07-19 21:16:22 +0200
commit4fb270171d96e55c851e1493b18dfee1b3a4139e (patch)
tree338303b1bd88feb21122f9b5a20349b1fd42f34a /Makefile.am
parentace6bfa72525089790b773ab0178e6d1a129357f (diff)
downloadudev-4fb270171d96e55c851e1493b18dfee1b3a4139e.tar.gz
configure: allow to disable mtd_probe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index d2e9b855..e20694f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -295,17 +295,6 @@ libexec_PROGRAMS += extras/v4l_id/v4l_id
dist_udevrules_DATA += extras/v4l_id/60-persistent-v4l.rules
# ------------------------------------------------------------------------------
-# mtd_probe - autoloads FTL module for mtd devices
-# ------------------------------------------------------------------------------
-extras_mtd_probe_mtd_probe_SOURCES = \
- extras/mtd_probe/mtd_probe.c \
- extras/mtd_probe/mtd_probe.h \
- extras/mtd_probe/probe_smartmedia.c
-extras_mtd_probe_mtd_probe_CPPFLAGS = $(AM_CPPFLAGS)
-dist_udevrules_DATA += extras/mtd_probe/75-probe_mtd.rules
-libexec_PROGRAMS += extras/mtd_probe/mtd_probe
-
-# ------------------------------------------------------------------------------
# accelerometer - updates device orientation
# ------------------------------------------------------------------------------
extras_accelerometer_accelerometer_SOURCES = extras/accelerometer/accelerometer.c
@@ -334,6 +323,20 @@ dist_udevrules_DATA += \
extras/rule_generator/75-persistent-net-generator.rules
endif
+if ENABLE_MTD_PROBE
+# ------------------------------------------------------------------------------
+# mtd_probe - autoloads FTL module for mtd devices
+# ------------------------------------------------------------------------------
+extras_mtd_probe_mtd_probe_SOURCES = \
+ extras/mtd_probe/mtd_probe.c \
+ extras/mtd_probe/mtd_probe.h \
+ extras/mtd_probe/probe_smartmedia.c
+extras_mtd_probe_mtd_probe_CPPFLAGS = $(AM_CPPFLAGS)
+dist_udevrules_DATA += extras/mtd_probe/75-probe_mtd.rules
+libexec_PROGRAMS += extras/mtd_probe/mtd_probe
+
+endif
+
if ENABLE_HWDB
# ------------------------------------------------------------------------------
# usb/pci-db - read vendor/device string database