aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2011-01-25 15:51:07 +0100
committerKay Sievers <kay.sievers@vrfy.org>2011-01-25 16:14:04 +0100
commit4e54f5334e130dc8f627c96ef2179ff4262b7791 (patch)
tree64fdde91c48b465c8c4ab2fbb9481fb4269a50b1 /Makefile.am
parent2514465f6a4ab61617482f068e475b945438c1f1 (diff)
downloadudev-4e54f5334e130dc8f627c96ef2179ff4262b7791.tar.gz
extras: add rules for qemu guests
These patches enable usb autosuspend for the qemu emulated HID devices. This reduces the cpu load for idle guests with a hid device attached because the linux kernel will suspend the usb bus then and qemu can stop running a 1000 Hz to emulate the (active) UHCI controller. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e3fe394..b2300ce7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -317,6 +317,11 @@ extras_v4l_id_v4l_id_LDADD = libudev/libudev-private.la
libexec_PROGRAMS += extras/v4l_id/v4l_id
dist_udevrules_DATA += extras/v4l_id/60-persistent-v4l.rules
+# ------------------------------------------------------------------------------
+# qemu -- qemu/kvm guest tweaks
+# ------------------------------------------------------------------------------
+dist_udevrules_DATA += extras/qemu/99-qemu-usb.rules
+
if ENABLE_EXTRAS
# ------------------------------------------------------------------------------
# conditional extras (need glib, libusb, libacl, ...)