aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2009-11-08 12:25:55 -0500
committerDavid Zeuthen <davidz@redhat.com>2009-11-08 12:31:35 -0500
commit4e3664f22b39c3efa33f5778a651a083b5e1f544 (patch)
tree16fbba2a4bec1363bb13ac07c1dc9405664e1e94 /Makefile.am
parent368d325ba8a53090a3bb71cbdbe25e11d70fff02 (diff)
downloadudev-4e3664f22b39c3efa33f5778a651a083b5e1f544.tar.gz
gudev: Fix up GUdevDeviceNumber
Actually dev_t is an unsigned quad type (e.g. 64-bit even on 32-bit x86) so defining it to be an integer is wrong and not future proof. Thus, redefine it to actually be a dev_t (as originally wanted) and instead add a work-around for GNOME bug #584517, see https://bugzilla.gnome.org/show_bug.cgi?id=584517 for details. This way, GObject Introspection will still work. This change is technically an API/ABI break but - all released GUdev versions requires the user to understand that the API/ABI is unstable by requiring the G_UDEV_API_IS_SUBJECT_TO_CHANGE symbols to be defined - functions using GUdevDeviceNumber are rarely used so we don't bump the so number. Signed-off-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2185614c..92598a60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -378,7 +378,7 @@ extras/gudev/GUdev-1.0.gir: extras/gudev/libgudev-1.0.la $(G_IR_SCANNER) Makefil
--pkg=gobject-2.0 \
-I$(top_srcdir)/extras \
-D_GUDEV_COMPILATION \
- -DG_UDEV_API_IS_SUBJECT_TO_CHANGE \
+ -D_GUDEV_WORK_AROUND_DEV_T_BUG \
$(top_srcdir)/extras/gudev/gudev.h \
$(top_srcdir)/extras/gudev/gudevtypes.h \
$(top_srcdir)/extras/gudev/gudevenums.h \