aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2010-03-18 17:13:59 -0700
committerDan Williams <dcbw@redhat.com>2010-03-18 17:13:59 -0700
commit4dd9b291354e76f34b0d6d7b5c3b28d03a624418 (patch)
tree384804ef320f8344b1a97aa1cdbc81b5d46d0b63 /Makefile.am
parent38a3cde11bc77af49a96245b8a8a0f2b583a344c (diff)
downloadudev-4dd9b291354e76f34b0d6d7b5c3b28d03a624418.tar.gz
modeswitch: morph into tool that only switches Mobile Action cables
Remove option modeswitching code; use usb_modeswitch already, people.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 12 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 99a0133b..68a68d91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -448,24 +448,21 @@ extras_usb_db_pci_db_LDADD = libudev/libudev-private.la
libexec_PROGRAMS += extras/usb-db/pci-db
# ------------------------------------------------------------------------------
-# modem-modeswitch - magic config switch for 3G modems
-# ------------------------------------------------------------------------------
-extras_modem_modeswitch_modem_modeswitch_SOURCES =\
- extras/modem-modeswitch/modem-modeswitch.c \
- extras/modem-modeswitch/utils.c \
- extras/modem-modeswitch/utils.h \
- extras/modem-modeswitch/ma8280p_us.c \
- extras/modem-modeswitch/ma8280p_us.h \
- extras/modem-modeswitch/option.c \
- extras/modem-modeswitch/option.h
-extras_modem_modeswitch_modem_modeswitch_CPPFLAGS = $(AM_CPPFLAGS) $(LIBUSB_CFLAGS)
-extras_modem_modeswitch_modem_modeswitch_LDADD = libudev/libudev-private.la $(LIBUSB_LIBS)
+# mobile-action-modeswitch - switch Mobile Action cables into serial mode
+# ------------------------------------------------------------------------------
+extras_mobile_action_modeswitch_mobile_action_modeswitch_SOURCES =\
+ extras/mobile-action-modeswitch/mobile-action-modeswitch.c \
+ extras/mobile-action-modeswitch/utils.c \
+ extras/mobile-action-modeswitch/utils.h \
+ extras/mobile-action-modeswitch/ma8280p_us.c \
+ extras/mobile-action-modeswitch/ma8280p_us.h
+extras_mobile_action_modeswitch_mobile_action_modeswitch_CPPFLAGS = $(AM_CPPFLAGS) $(LIBUSB_CFLAGS)
+extras_mobile_action_modeswitch_mobile_action_modeswitch_LDADD = libudev/libudev-private.la $(LIBUSB_LIBS)
dist_udevrules_DATA += \
- extras/modem-modeswitch/61-option-modem-modeswitch.rules \
- extras/modem-modeswitch/61-mobile-action.rules
+ extras/mobile-action-modeswitch/61-mobile-action.rules
-libexec_PROGRAMS += extras/modem-modeswitch/modem-modeswitch
+libexec_PROGRAMS += extras/mobile-action-modeswitch/mobile-action-modeswitch
# ------------------------------------------------------------------------------
# keymap - map custom hardware's multimedia keys