aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-08-07 02:23:01 +0200
committerKay Sievers <kay.sievers@vrfy.org>2009-08-07 19:15:28 +0200
commit405e606f8649fd87a8a1d2e5a6399c27dcae28b8 (patch)
treef24978889764416c8f12150e8f0e3d864a48f3d2 /Makefile.am
parent59d93adb29fae25220955d44a5cd25f0d99e3528 (diff)
downloadudev-405e606f8649fd87a8a1d2e5a6399c27dcae28b8.tar.gz
Replace the custom test-run target with the standard make check.
A little fix is needed for the udev-test.pl script (to be called with the proper path), but this allows for the test binaries to be only built when running the tests themselves.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b18ac91f..6aacd7be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,9 +41,6 @@ changelog:
@ cat ChangeLog.tmp >> ChangeLog
@ rm ChangeLog.tmp
-test-run:
- cd test && ./udev-test.pl
-
test-install:
rm -rf $(PWD)/udev-test-install/
make DESTDIR=$(PWD)/udev-test-install install
@@ -190,6 +187,9 @@ extras_v4l_id_v4l_id_LDADD = libudev/libudev-private.la
# ------------------------------------------------------------------------------
# Tests
# ------------------------------------------------------------------------------
+
+TESTS = test/udev-test.pl
+
check_PROGRAMS = \
libudev/test-libudev \
udev/test-udev