aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2012-01-12 16:30:12 +0100
committerKay Sievers <kay.sievers@vrfy.org>2012-01-12 18:52:21 +0100
commit338dc67a005fd0ed9a8a3524d2b317e33ab33c9f (patch)
tree6e4d5bd6f406888fb7879d0250457ad5edcca0fa /Makefile.am
parenta5f834204f375519b178f98770f8cfd9668a4603 (diff)
downloadudev-338dc67a005fd0ed9a8a3524d2b317e33ab33c9f.tar.gz
Makefile: update kernel.org doc hooks for kup
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d3d9570e..04db95fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -771,6 +771,9 @@ tar-sync:
kup put udev-$(VERSION).tar.xz udev-$(VERSION).tar.asc /pub/linux/utils/kernel/hotplug/udev-$(VERSION).tar.gz
doc-sync:
- rsync -av src/*.html master.kernel.org:/pub/linux/utils/kernel/hotplug/udev/
- rsync -av --delete src/docs/html/ master.kernel.org:/pub/linux/utils/kernel/hotplug/src/
- rsync -av --delete src/extras/gudev/docs/html/ master.kernel.org:/pub/linux/utils/kernel/hotplug/gudev/
+ for i in src/*.html; do rm -f $$i.sign; gpg --armor --detach-sign --output=$$i.sign $$i; done
+ for i in src/*.html; do echo $$i; kup put $$i $$i.sign /pub/linux/utils/kernel/hotplug/udev/; done
+ for i in src/docs/html/*.{html,css,png}; do rm -f $$i.sign; gpg --armor --detach-sign --output=$$i.sign $$i; done
+ for i in src/docs/html/*.{html,css,png}; do echo $$i; kup put $$i $$i.sign /pub/linux/utils/kernel/hotplug/libudev/; done
+ for i in src/extras/gudev/docs/html/*.{html,css,png}; do rm -f $$i.sign; gpg --armor --detach-sign --output=$$i.sign $$i; done
+ for i in src/extras/gudev/docs/html/*.{html,css,png}; do echo $$i; kup put $$i $$i.sign /pub/linux/utils/kernel/hotplug/gudev/; done