aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-09-01 04:47:16 +0200
committerLennart Poettering <lennart@poettering.net>2009-09-01 04:47:16 +0200
commit1032141bd580b20bfe6c5efe737eb6e3fa595d06 (patch)
tree2863da5a4f75d3a044bdf734af54876066ee81cb /Makefile.am
parent71b4b701b1c5261de0dba5b071ec10089361de0e (diff)
downloadudev-1032141bd580b20bfe6c5efe737eb6e3fa595d06.tar.gz
pci-db: make sure we actually read the pci.ids file instead of usb.ids
Since the recent Makefile.am rework both usb-db and pci-db were built to read the usb.ids database file. This fix makes sure pci-db properly reads pci.ids instead. Originally pointed out by Marco d'Itri.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d785f056..61fbf222 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -439,7 +439,7 @@ libexec_PROGRAMS += extras/usb-db/usb-db
# pci-db - read PCI vendor/device string database
# ------------------------------------------------------------------------------
extras_usb_db_pci_db_SOURCES = extras/usb-db/usb-db.c
-extras_usb_db_pci_db_CPPFLAGS = $(AM_CPPFLAGS) -DPCI_DATABASE=\"$(USB_DATABASE)\" -DBUILD_FOR_PCI
+extras_usb_db_pci_db_CPPFLAGS = $(AM_CPPFLAGS) -DPCI_DATABASE=\"$(PCI_DATABASE)\" -DBUILD_FOR_PCI
extras_usb_db_pci_db_LDADD = libudev/libudev-private.la
libexec_PROGRAMS += extras/usb-db/pci-db