aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJunio C Hamano <junkio@cox.net>2005-08-06 13:10:43 -0700
committerJunio C Hamano <junkio@cox.net>2005-08-06 17:23:52 -0700
commit7a59013290bb26b80c997e5698757a735f1a92e0 (patch)
tree9658c6be6996dba62cc6c10d2c85b3bcc97621d9 /debian
parentd3af621b147bb90a31fdc3b55e07853f45deb658 (diff)
downloadgit-7a59013290bb26b80c997e5698757a735f1a92e0.tar.gz
GIT 0.99.4 (release candidate)
This is my first attempt to adjust Debian and RPM to pass prefix, to prepare the 0.99.4 release. It updates debian/rules and git-core.spec.in to properly pass prefix when building binary packages. It also updates debian/changelog to make the resulting binary package name 0.99.4; this is not needed on the RPM side (it takes the version number from the main Makefile). Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e62b783b3..5e86a86dc5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+git-core (0.99.4-1) unstable; urgency=low
+
+ * Pass prefix down to the submake when building.
+
+ -- Junio C Hamano <junkio@cox.net> Sat, 6 Aug 2005 13:00:00 -0700
+
git-core (0.99-2) unstable; urgency=low
* Conflict with the GNU Interactive Tools package, which also installs
diff --git a/debian/rules b/debian/rules
index 67830b03b9..1409b8b280 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ MAN_DESTDIR := $(DESTDIR)/$(MANDIR)
build: debian/build-stamp
debian/build-stamp:
dh_testdir
- $(MAKE) all doc
+ $(MAKE) prefix=$(PREFIX) all doc
touch debian/build-stamp
debian-clean: